Cloud Backupクライアントのステータスが異常な場合、バックアップおよび復元ジョブは失敗する可能性があります。 このトピックでは、Cloud Backupクライアントのステータス例外のトラブルシューティングと処理方法について説明します。
問題
Cloud Backupコンソールで、次のエラーが発生します。Cloud Backupクライアントのステータスが "Stopped" で、"Cloud Backupクライアントが正しく接続されていません" というメッセージが表示されます。 バックアップジョブのステータスが「Failed」で、「バックアップクライアントが接続を失うためにバックアップが失敗しました」というメッセージが表示されます。
原因
Cloud Backupクライアントのプロセスで例外が発生します。 たとえば、プロセスが停止しました。
Cloud Backupクライアントとサーバー間のネットワーク接続が異常です。 たとえば、ネットワークが切断されている、メッセージがファイアウォールによって傍受されている、またはクライアントの設定が正しくないなどです。
Cloud Backupクライアントの登録に失敗しました。 例えば、オンプレミスサーバのネットワークインターフェースコントローラ (NIC) が交換される。
解決策
Cloud Backupクライアントのステータスを確認します。
Cloud Backupクライアントのログを表示する方法の詳細については、Cloud Backupクライアントのデフォルトのインストールパスとログはどこで確認できますか。
ログとネットワークを確認します。
Cloud Backupクライアントのログとネットワークを確認します。 次に、クライアントをリセットして再起動します。
ログを確認します。
説明新しいCloud Backupクライアントは、デフォルトで次のいずれかのパスにインストールされます。 次のパスは参照専用です。 実際のインストールパスは異なる場合があります。
Windowsでは、C:\Program Files\Aliyun Hybrid Backup Service Client\logsパスでログを表示できます。
Linuxでは、/opt/alibabacloud/hbrclient/logsパスでログを表示できます。
ログファイルを開き、クライアントの登録に失敗したを検索します。 AppError: ErrorCode=
ErrorCodeパラメーターの値がInvalidInstanceIdの場合、ネットワーク接続は正常ですが、Cloud Backupクライアントの登録に失敗します。 ステップiiiを実行する。
ErrorCodeパラメーターの値がInvalidInstanceIdでない場合は、Cloud Backupサービスを再起動します。 Linuxでは、
service hbrclient restart
コマンドを実行して、Cloud Backupサービスを再起動できます。例外が解決しない場合は、ステップiiを実行してネットワークステータスを確認します。
それでも登録が失敗すると、
チケットを起票してサポートセンターにお問い合わせくださいしてサポートセンターにお問い合わせください。
サーバのネットワーク状態を確認してください。
ネットワークを監視するには、診断ツールfor Cloud Backupクライアントを使用することを推奨します。 一般的なネットワークの問題の詳細については、「一般的なネットワークの問題」をご参照ください。
クライアントのnetwork.logファイルを開きます。
Failed on pingがログファイルに含まれている場合、ネットワーク例外が発生しています。 例外は、ファイアウォールとルート設定によって発生する可能性があります。 サーバーが配置されているネットワークのITエンジニアに連絡し、対応するリージョンのインターネットエンドポイントまたはECS内部エンドポイントを設定します。 エンドポイントの詳細については、クライアント接続例外が発生した場合はどうすればよいですか。
pingに失敗しましたがログファイルに含まれていない場合は、ステップiv.
サーバのNICが交換されているか確認してください。
サーバのNICが交換されたかどうかは、サーバが配置されているネットワークのITエンジニアに連絡してください。
古いCloud Backupクライアントの場合、サーバーがクローンされているかどうかを確認します。
サーバーが配置されているネットワークのITエンジニアに連絡して、サーバーがクローンされているかどうかを確認してください。
サーバーがクローンされている場合、サーバーにインストールされているCloud Backupクライアントもクローンされています。 その結果、クローンサーバー上のCloud Backupクライアントの登録に失敗します。
元のサーバー上のCloud Backupクライアントがまだ使用されている場合は、クローンされたサーバー上のCloud Backupクライアントをアンインストールし、Cloud Backupクライアントを再インストールします。
元のサーバーのCloud Backupクライアントが使用されていない場合は、手順viを実行して、クローンされたサーバーのCloud Backupクライアントを再アクティブ化します。
サーバーがクローンされていない場合は、ステップv.
サーバーのオペレーティングシステムが再インストールされているかどうかを確認します。
説明サーバーのオペレーティングシステムが再インストールされると、Cloud BackupクライアントはCloud Backupコンソールから切断されます。 その結果、Cloud BackupコンソールにCloud Backupクライアントのステータスが異常として表示されます。 Cloud Backupクライアントを再インストールして登録すると、同じ名前の別のCloud Backupクライアントが表示されます。
この場合、最初に新しいCloud Backupクライアントを停止します。
Cloud Backupコンソールで、古いCloud Backupクライアントの再アクティブ化コマンドとトークンを取得します。 クライアントが1時間以上切断された場合にのみ、クライアントを再アクティブ化できます。 再アクティブ化が利用できない場合は、しばらく待ってからもう一度やり直してください。
取得した再アクティブ化コマンドを、サーバー上の対応するクライアントのインストールディレクトリで実行します。
古いCloud BackupクライアントのステータスがCloud Backupコンソールで [有効化] と表示されるまで待ちます。
Cloud Backupコンソールで、例外が発生した新しいCloud Backupクライアントをアンインストールします。
例外が解決しない場合は、Cloud Backupクライアントを再アクティブ化します。
にログインします。Cloud Backupコンソール.
ファイルバックアップのデータソースを選択します。
ECS ファイルバックアップ
左側のナビゲーションペインで、
を選択します。オンプレミスのファイルバックアップ
左側のナビゲーションウィンドウで、
を選択します。
上部のナビゲーションバーで、リージョンを選択します。
再アクティブ化するCloud Backupクライアントを見つけ、 [アクション] 列に表示されます。
[クライアントの再アクティブ化] パネルで、コマンドをコピーします。 次に、サーバーのクライアントインストールディレクトリでコマンドを実行し、Cloud Backupクライアントがアクティブになるまで待ちます。
クライアントがアクティブ化されると、[クライアントステータス] 列の値が [アクティブ化] に変わります。
上記の操作を実行しても問題が解決しない場合は、
チケットを起票してサポートセンターにお問い合わせくださいしてサポートセンターにお問い合わせください。