Cloud Backup クライアントのステータスが異常な場合、バックアップジョブと復元ジョブが失敗する可能性があります。このトピックでは、Cloud Backup クライアントのステータス例外をトラブルシューティングおよび処理する方法について説明します。
問題
Cloud Backup コンソールで、次のエラーが発生します。
クライアントステータスが「停止」になり、次のエラーメッセージが表示されます。Cloud Backup クライアントが正しく接続されていません。
バックアップジョブが失敗し、次のエラーメッセージが表示されます。バックアップクライアントの接続が失われたため、バックアップに失敗しました。


原因
Cloud Backup クライアントのプロセスで例外が発生しました。たとえば、プロセスが停止しています。その結果、バックアップジョブが失敗します。
Cloud Backup クライアントとサーバー間のネットワーク接続が異常です。たとえば、ネットワークが切断されている、メッセージがファイアウォールによってインターセプトされている、またはクライアント設定が正しくないなどです。その結果、バックアップジョブが失敗します。
Cloud Backup クライアントの登録に失敗しました。たとえば、オンプレミスサーバーのネットワークインターフェースコントローラー(NIC)が交換されています。その結果、バックアップジョブが失敗します。
バックアップジョブの実行中に Cloud Backup クライアントが停止しました。その結果、バックアッププロセスが失われ、サーバーがバックアップステータスを取得できなくなり、バックアップジョブがタイムアウトします。
解決策
Cloud Backup クライアントのステータスを確認します。
Cloud Backup クライアントのログを表示する方法の詳細については、「Cloud Backup クライアントのデフォルトのインストールパスとログはどこで表示できますか?」をご参照ください。
ログとネットワークを確認します。
Cloud Backup クライアントのログとネットワークを確認します。次に、クライアントをリセットして再アクティブ化します。
ログを確認します。
説明新しい Cloud Backup クライアントは、デフォルトで次のいずれかのパスにインストールされます。次のパスは参照用です。実際のインストールパスは異なる場合があります。
Windows では、C:\Program Files\Aliyun Hybrid Backup Service Client\logs パスでログを表示できます。
Linux では、/opt/alibabacloud/hbrclient/logs パスでログを表示できます。
ログファイルを開き、Failed to register client. AppError: ErrorCode= を検索します。
ErrorCode パラメーターの値が InvalidInstanceId の場合、ネットワーク接続は正常ですが、Cloud Backup クライアントの登録に失敗しています。手順 iii を実行します。
ErrorCode パラメーターの値が InvalidInstanceId でない場合は、Cloud Backup サービスを再起動します。Linux では、
service hbrclient restartコマンドを実行して、Cloud Backup サービスを再起動できます。例外が解決しない場合は、手順 ii を実行してネットワークステータスを確認します。
登録がまだ失敗する場合は、チケットを送信 します。
ログファイルに Program Stopped! が含まれている場合、バックアップジョブの実行中に Cloud Backup クライアントが停止しています。その結果、バックアッププロセスが失われ、サーバーがバックアップステータスを取得できなくなり、バックアップジョブがタイムアウトします。Cloud Backup クライアントのステータスを表示 できます。クライアントが起動している場合、後続のバックアップは正しく実行されます。

サーバーのネットワークステータスを確認します。
Cloud Backup クライアントの診断ツール を使用してネットワークを監視することをお勧めします。一般的なネットワークの問題の詳細については、「一般的なネットワークの問題」をご参照ください。
クライアントの network.log ファイルを開きます。
ログファイルに Failed on ping が含まれている場合、ネットワーク例外が発生しています。この例外は、ファイアウォールとルートの構成が原因である可能性があります。サーバーが配置されているネットワークの IT エンジニアに連絡し、対応するリージョンのインターネットエンドポイントまたは ECS 内部エンドポイントを設定します。エンドポイントの詳細については、「クライアント接続の例外が発生した場合の対処方法」をご参照ください。
ログファイルに Failed on ping が含まれていない場合は、手順 iv を実行します。
サーバーの NIC が交換されているかどうかを確認します。
サーバーが配置されているネットワークの IT エンジニアに連絡して、サーバーの NIC が交換されているかどうかを確認します。
古い Cloud Backup クライアントの場合、サーバーが複製されているかどうかを確認します。
サーバーが配置されているネットワークの IT エンジニアに連絡して、サーバーが複製されているかどうかを確認します。
サーバーが複製されている場合、サーバーにインストールされている Cloud Backup クライアントも複製されています。その結果、複製されたサーバー上の Cloud Backup クライアントの登録に失敗します。
元のサーバーの Cloud Backup クライアントがまだ使用されている場合は、複製されたサーバーの Cloud Backup クライアントをアンインストールし、Cloud Backup クライアントを再インストールします。
元のサーバーの Cloud Backup クライアントが使用されていない場合は、手順 vi を実行して、複製されたサーバーの Cloud Backup クライアントを再アクティブ化します。
サーバーが複製されていない場合は、手順 v を実行します。
サーバーのオペレーティングシステムが再インストールされているかどうかを確認します。
説明サーバーのオペレーティングシステムが再インストールされると、Cloud Backup クライアントは Cloud Backup コンソールから切断されます。その結果、Cloud Backup クライアントのステータスは、Cloud Backup コンソールで「異常」と表示されます。Cloud Backup クライアントを再インストールして登録すると、同じ名前の別の Cloud Backup クライアントが表示されます。
この場合は、最初に新しい Cloud Backup クライアントを停止します。
Cloud Backup コンソールで、古い Cloud Backup クライアントの再アクティブ化コマンドとトークンを取得します。クライアントは、クライアントが 1 時間以上切断されている場合にのみ再アクティブ化できます。「再アクティブ化」が使用できない場合は、しばらく待ってから再試行してください。
取得した再アクティブ化コマンドを、サーバー上の対応するクライアントインストールディレクトリで実行します。
古い Cloud Backup クライアントのステータスが Cloud Backup コンソールで「アクティブ化済み」と表示されるまで待ちます。
Cloud Backup コンソールで、例外が発生している新しい Cloud Backup クライアントをアンインストールします。
例外が解決しない場合は、Cloud Backup クライアントを再アクティブ化します。
Cloud Backup コンソール にログオンします。
ファイルバックアップのデータソースを選択します。
ECS ファイルバックアップ
左側のナビゲーションウィンドウで、 を選択します。
オンプレミスファイルバックアップ
左側のナビゲーションウィンドウで、 を選択します。
上部のナビゲーションバーで、リージョンを選択します。
再アクティブ化する Cloud Backup クライアントを見つけ、「操作」列で を選択します。
[クライアントの再アクティブ化] パネルで、コマンドをコピーします。次に、サーバー上のクライアントインストールディレクトリでコマンドを実行し、Cloud Backup クライアントがアクティブになるまで待ちます。
クライアントがアクティブになると、[クライアントステータス] 列の値が [アクティブ化済み] に変わります。
上記の操作を実行した後も問題が解決しない場合は、チケットを送信 します。