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檔案備份用戶端狀態異常處理

更新時間:2025-02-17 19:31

檔案備份用戶端狀態異常,可能導致備份和恢複任務執行失敗。本文介紹排查和處理檔案備份用戶端狀態異常操作方法。

  • 問題現象

    在雲備份控制台中,您可能會遇到以下情況:

    1. 用戶端狀態顯示為“已停止”,並提示“用戶端未正常串連”。

    2. 備份任務執行失敗,錯誤資訊為“備份用戶端失去串連導致備份失敗”。

    image

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  • 問題原因

    • 檔案備份用戶端程式運行異常(如進程已停止),導致備份任務執行失敗。

    • 檔案備份用戶端與服務端之間的網路連接異常(如網路不通、防火牆攔截或用戶端設定不正確)導致備份任務執行失敗。

    • 檔案備份用戶端註冊失敗(如因本機伺服器更換網卡)導致備份任務執行失敗。

    • 檔案備份用戶端在備份任務執行期間被停止,導致備份進程丟失,服務端無法擷取備份狀態,從而引發備份任務逾時失敗。

  • 解決方案

    1. 檢查檔案備份用戶端運行狀態。

      Windows系統

      當前支援的Windows版本備份用戶端存在新版和舊版之分,新版和舊版的區別如下:

      • 新版檔案備份用戶端服務名稱為:Alibaba Cloud Hybrid Backup Service

      • 舊版檔案備份用戶端服務名稱為:Aliyun Hybrid Backup Service

      您可以使用以下方法查看用戶端的運行狀態:

      • 查看服務運行狀態

        說明

        在更改服務的啟動類型之前,請確保您瞭解服務的功能和作用,以避免對系統造成不良影響。對於某些服務,可能需要以管理員身份執行操作。

        1. 開啟服務管理器。可以通過以下方式開啟:

          • 使用快速鍵Win + R開啟運行對話方塊,輸入services.msc

          • 在Windows搜尋欄中輸入服務,然後單擊服務應用

        2. 服務管理器視窗中,您可以看到列出的所有Windows服務。

          • 要啟動服務,雙擊服務名稱,進入服務屬性視窗,然後單擊啟動按鈕。

          • 要停止服務,雙擊服務名稱,進入服務屬性視窗,然後單擊停止按鈕。

        3. 查看本地服務,如果程式運行正常,可以看到備份服務處於正在運行狀態。

      Linux系統

      當前支援的Linux版本備份用戶端存在新版和舊版之分,新版和舊版的區別如下:

      • 新版檔案備份用戶端服務進程為:hbrclient

      • 舊版檔案備份用戶端服務進程為:hybridbackup

      新版檔案備份用戶端(hbrclient)
      舊版檔案備份用戶端(hybridbackup)
      重啟或者重新安裝用戶端

      您可以使用以下方法查看用戶端的運行狀態:

      • 查看進程運行狀態

        執行systemctl status hbrclientservice hbrclient status或者ps axu|grep hbrclient命令,查看服務用戶端運行狀態。如果存在activerun,說明已經啟動,一切運行正常。

      • 查看連接埠是否正常開啟

        執行netstat -lpt | grep hbrclient命令,查看連接埠運行狀態。如果連接埠開啟正常,可以看到連接埠處於LISTEN狀態。

        tcp6       0      0 [::]:43565              [::]:*                  LISTEN      1727/hbrclient

      您可以使用以下方法查看用戶端的運行狀態:

      • 查看進程運行狀態

        執行ps axu|grep hybridbackup命令,如果存在結果,說明已經啟動,一切運行正常。

      • 查看連接埠8011是否正常開啟

        執行lsof -i:8011命令,查看連接埠運行狀態,如果連接埠開啟正常,可以看到連接埠處於LISTEN狀態。如果命令列提示command not found,您可以使用yum install lsofapt install lsof安裝lsof後重試。

        COMMAND     PID USER   FD   TYPE   DEVICE SIZE/OFF NODE NAME
        hybridbac 11477 username    5u  IPv6 10625414      0t0  TCP *:8011 (LISTEN)
      • 若用戶端沒有正常運行,您可以嘗試重啟備份服務。

        說明

        不同Linux作業系統指令不同:

        新版用戶端重啟命令:

        • systemctl restart hbrclient

        • systemctl restart hbrclientupdater

        舊版用戶端重啟命令:

        • systemctl restart hybridbackup

        • systemctl restart updater

      • 若用戶端仍然沒有正常運行,您可以卸載用戶端並重新安裝。具體操作,請參見如何卸載雲備份用戶端下載並啟用Linux用戶端

      如何查看備份用戶端日誌,請參見如何查看雲備份用戶端預設安裝路徑和日誌

    2. 檢查日誌和網路。

      檢查備份用戶端的作業記錄和網路情況,重新設定並啟用備份用戶端。

      1. 檢查作業記錄Log。

        說明

        新版備份用戶端預設安裝路徑參考如下,操作中請以實際安裝路徑為準。

        • Windows版本日誌路徑:本地磁碟(C)> Program Files > Aliyun Hybrid Backup Service Client > logs

        • Linux版本日誌路徑:/opt/alibabacloud/hbrclient/logs

        1. 開啟Log檔案,搜尋Failed to register client. AppError: ErrorCode=

        2. 若ErrorCode為InvalidInstanceId,則表示網路正常但備份用戶端註冊失敗,執行步驟

        3. 若ErrorCode不為InvalidInstanceId,則重啟雲備份服務。Linux系統可執行service hbrclient restart重啟雲備份服務。

        4. 若仍然異常,請檢查網路狀態,執行步驟

        5. 若仍然註冊失敗,請提交工單擷取支援。

        6. 若記錄檔中出現Program Stopped!,則表示檔案備份用戶端在備份任務執行期間被停止,導致備份進程丟失,服務端無法擷取備份狀態,從而引發備份任務逾時失敗。您可以查看檔案備份用戶端運行狀態,如果已經正常啟動,後續備份將正常執行。

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      2. 檢查伺服器網路狀態。

        1. 建議使用雲備份用戶端問題診斷工具對用戶端所處網路環境進行監測。常見網路問題,請參見常見網路問題

        2. 開啟用戶端network.log檔案。

        3. 若記錄檔中出現Failed on ping,則表示網路異常(包括防火牆和路由配置等異常)。請您聯絡伺服器所在網路的IT支撐人員,根據網路存取點設定雲備份對應地區的公網存取點或ECS內網存取點。

        4. 若未搜尋到Failed on ping,執行步驟

      3. 確認伺服器是否更換過網卡。

        聯絡伺服器所在網路的IT支撐人員,確認安裝過備份用戶端的伺服器是否更換過網卡。

        1. 若更換過網卡,則該操作會導致伺服器MAC地址變化,導致備份用戶端無法註冊,從而備份用戶端狀態異常。請按照步驟重新啟用備份用戶端。

        2. 若未更換過網卡,執行步驟

      4. 如果為舊版用戶端,請檢查伺服器是否被複製過。

        聯絡伺服器所在網路的IT支撐人員,確認安裝過備份用戶端的伺服器是否被複製過。

        1. 若被複製過,則該操作會導致安裝的備份用戶端也被複製,從而導致複製出來的伺服器上的備份用戶端註冊失敗。

          • 若原伺服器備份用戶端仍在使用,請在複製出來的伺服器上卸載備份用戶端後,重新安裝備份用戶端即可。

          • 若原伺服器備份用戶端未使用,則在複製出來的伺服器上,按照步驟重新啟用用戶端。

        2. 若未被複製過,執行步驟

      5. 請檢查伺服器作業系統是否重新安裝過。

        說明

        重新安裝伺服器作業系統後,檔案備份用戶端會和雲備份控制台之間失去聯絡,造成檔案備份用戶端在雲備份控制台顯示異常。您重新安裝檔案備份用戶端並註冊後,會出現第二台名稱相同的檔案備份用戶端。

        1. 先停止新檔案備份用戶端服務。

        2. Cloud Backup控制台擷取舊檔案備份用戶端的重新啟用Token(包含執行命令和Token)。用戶端失聯一個小時後才允許重新啟用,若無法點擊重新啟用請稍等。

        3. 在伺服器對應用戶端目錄執行擷取的重新啟用命令。

        4. 等待一會兒,Cloud Backup控制台的舊檔案用戶端顯示為已啟用。

        5. 在雲備份控制台,刪除已經異常的新檔案備份用戶端。

      6. 如果還是異常,請重新啟用檔案備份用戶端。

        1. 登入雲備份Cloud Backup控制台

        2. 選擇備份資料來源。

          • ECS檔案備份

            在左側導覽列,選擇備份 > ECS檔案備份

          • 本地檔案備份

            在左側導覽列,選擇備份 > 本地檔案備份

        3. 在頂部功能表列左上方,選擇所在地區。

        4. 找到目標備份用戶端,在其右側的操作欄選擇更多 > 重新啟用用戶端

        5. 重新啟用用戶端面板,拷貝命令。並在伺服器上的用戶端安裝目錄下執行該命令,等待啟用成功。

        啟用完成後,用戶端狀態顯示為已啟用

      7. 如果以上排查仍未解決問題,請提交工單擷取支援。

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