檔案備份用戶端狀態異常,可能導致備份和恢複任務執行失敗。本文介紹排查和處理檔案備份用戶端狀態異常操作方法。
問題現象
在雲備份控制台中,您可能會遇到以下情況:
用戶端狀態顯示為“已停止”,並提示“用戶端未正常串連”。
備份任務執行失敗,錯誤資訊為“備份用戶端失去串連導致備份失敗”。
問題原因
檔案備份用戶端程式運行異常(如進程已停止),導致備份任務執行失敗。
檔案備份用戶端與服務端之間的網路連接異常(如網路不通、防火牆攔截或用戶端設定不正確)導致備份任務執行失敗。
檔案備份用戶端註冊失敗(如因本機伺服器更換網卡)導致備份任務執行失敗。
檔案備份用戶端在備份任務執行期間被停止,導致備份進程丟失,服務端無法擷取備份狀態,從而引發備份任務逾時失敗。
解決方案
檢查檔案備份用戶端運行狀態。
如何查看備份用戶端日誌,請參見如何查看雲備份用戶端預設安裝路徑和日誌。
檢查日誌和網路。
檢查備份用戶端的作業記錄和網路情況,重新設定並啟用備份用戶端。
檢查作業記錄Log。
新版備份用戶端預設安裝路徑參考如下,操作中請以實際安裝路徑為準。
Windows版本日誌路徑:本地磁碟(C)> Program Files > Aliyun Hybrid Backup Service Client > logs
Linux版本日誌路徑:/opt/alibabacloud/hbrclient/logs
開啟Log檔案,搜尋Failed to register client. AppError: ErrorCode=。
若ErrorCode為InvalidInstanceId,則表示網路正常但備份用戶端註冊失敗,執行步驟Ⅲ。
若ErrorCode不為InvalidInstanceId,則重啟雲備份服務。Linux系統可執行
service hbrclient restart
重啟雲備份服務。若仍然異常,請檢查網路狀態,執行步驟Ⅱ。
若仍然註冊失敗,請提交工單擷取支援。
若記錄檔中出現Program Stopped!,則表示檔案備份用戶端在備份任務執行期間被停止,導致備份進程丟失,服務端無法擷取備份狀態,從而引發備份任務逾時失敗。您可以查看檔案備份用戶端運行狀態,如果已經正常啟動,後續備份將正常執行。
檢查伺服器網路狀態。
建議使用雲備份用戶端問題診斷工具對用戶端所處網路環境進行監測。常見網路問題,請參見常見網路問題。
開啟用戶端network.log檔案。
若記錄檔中出現Failed on ping,則表示網路異常(包括防火牆和路由配置等異常)。請您聯絡伺服器所在網路的IT支撐人員,根據網路存取點設定雲備份對應地區的公網存取點或ECS內網存取點。
若未搜尋到Failed on ping,執行步驟Ⅳ。
確認伺服器是否更換過網卡。
聯絡伺服器所在網路的IT支撐人員,確認安裝過備份用戶端的伺服器是否更換過網卡。
如果為舊版用戶端,請檢查伺服器是否被複製過。
聯絡伺服器所在網路的IT支撐人員,確認安裝過備份用戶端的伺服器是否被複製過。
請檢查伺服器作業系統是否重新安裝過。
重新安裝伺服器作業系統後,檔案備份用戶端會和雲備份控制台之間失去聯絡,造成檔案備份用戶端在雲備份控制台顯示異常。您重新安裝檔案備份用戶端並註冊後,會出現第二台名稱相同的檔案備份用戶端。
先停止新檔案備份用戶端服務。
在Cloud Backup控制台擷取舊檔案備份用戶端的重新啟用Token(包含執行命令和Token)。用戶端失聯一個小時後才允許重新啟用,若無法點擊重新啟用請稍等。
在伺服器對應用戶端目錄執行擷取的重新啟用命令。
等待一會兒,Cloud Backup控制台的舊檔案用戶端顯示為已啟用。
在雲備份控制台,刪除已經異常的新檔案備份用戶端。
如果還是異常,請重新啟用檔案備份用戶端。
選擇備份資料來源。
ECS檔案備份
在左側導覽列,選擇
。本地檔案備份
在左側導覽列,選擇
。
在頂部功能表列左上方,選擇所在地區。
找到目標備份用戶端,在其右側的操作欄選擇 。
在重新啟用用戶端面板,拷貝命令。並在伺服器上的用戶端安裝目錄下執行該命令,等待啟用成功。
啟用完成後,用戶端狀態顯示為已啟用。
如果以上排查仍未解決問題,請提交工單擷取支援。