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Server Migration Center:What do I do if I receive an S0 error code indicating that the SMC client fails to invoke the SMC service?

Last Updated:Mar 04, 2024

This topic describes the cause of the "S0_* An error occurred in the invocation of SMC by the SMC client." error message that is reported when you use Server Migration Center (SMC) to run a migration job. This topic also describes how to resolve the error.

Problem description

During an SMC migration job, the "S0_* An error occurred in the invocation of SMC by the SMC client." error message is reported. The following S0_* error codes may be reported:

  • S0_U28

  • S0_U7

  • S0_U56

  • S0_U6

  • S0_U35

Cause

The source server cannot access the endpoint of SMC.

Solution

  1. Check the endpoint of SMC.

    • If the information about the migration source is automatically imported by using the console or the migration source is activated by using an activation code, one of the following endpoints is used:

      • Default public endpoint: https://smc-service.aliyuncs.com.

      • Internal endpoint: https://<region-id>.axt.aliyun.com. Only Elastic Compute Service (ECS) instances can access the internal endpoint.

    • If the information about the migration source is manually imported by using the SMC client and the migration source is activated by using an AccessKey pair, one of the following endpoints is used:

      • Default public endpoint: https://smc.aliyuncs.com. The IP addresses of the servers are 101.37.132.1 and 47.111.202.72.

      • Internal endpoint: https://smc.vpc-proxy.aliyuncs.com. Only ECS instances can access the internal endpoint.

    Note

    By default, all SMC endpoints use HTTPS port 443. HTTP port 80 may not be supported.

  2. Check whether the network service of the source server is normal.

    1. Check whether the local network service of the source server is normal and whether the configurations such as the hosts file and Domain Name System (DNS) settings are valid.

    2. By default, SMC migrates data over the Internet. Make sure that the source server can access the Internet.

    3. If you migrate data over a VPC, make sure that the source server is connected to the specified VPC and vSwitch. For more information, see Migrate servers over a VPC.

      Note

      If you are not sure whether the source server is connected to the specified VPC and vSwitch, we recommend that you set the Network Type parameter to Public Network when you create a migration job. If you set the Network Type parameter to VPC and the migration job fails, change the value of the Network Type parameter to Public Network and try again.

  3. Check whether the network connection from the source server to the SMC endpoint is normal.

    1. Run the ping command in the source server to test whether the network connection from the source server to the SMC endpoint is normal.

      If the network is disconnected, check the local network configurations or intermediate network devices. For example, check whether the IP address of the SMC endpoint is blocked by the firewall or whether the proxy server forbids outbound traffic to the IP address of the SMC endpoint.

    2. Run the curl command on a Linux operating system or visit the SMC endpoint by using a browser on a Windows operating system to test whether the source server can access the SMC endpoint.

      If the test fails, check the local network configurations or intermediate network devices. For example, check whether the IP address and port of the SMC endpoint are blocked by the firewall or whether the proxy server forbids outbound traffic to the IP address and port of the SMC endpoint.

  4. After the error is resolved, run the SMC client and retry the migration job. For more information, see Run the SMC client.