All Products
Search
Document Center

Simple Application Server:Network speed of a simple application server does not match the expected network bandwidth of the server

Last Updated:Aug 21, 2024

This topic describes the description, causes, and solutions of the problem that the network speed of a simple application server does not match the expected network bandwidth of the server.

Problem description

When you access a website or an application on an Alibaba Cloud simple application server, the network access speed is slow, which does not match the expected bandwidth that you specify.

Causes

  • The simple application server is deployed in the China (Hong Kong) region. If you use a client in the Chinese mainland to access a simple application server that is deployed outside the Chinese mainland, the network connection fails. However, a client outside the Chinese mainland can access the simple application server. Route tracking analytics shows that the abnormal node is located at the egress of the cross-border interconnection. Alibaba Cloud has reported the fault to the Internet service provider (ISP) but has not received feedback.

  • The bandwidth of the server is exhausted.

  • The network of the on-premises device is unstable.

  • You have overdue payments for the server.

Solutions

Select one of the following solutions based on the causes of the problem:

  • If your simple application server is deployed in the China (Hong Kong) region, you can test whether other servers outside the Chinese mainland also have slow access speed. If the same issue occurs on other servers outside the Chinese mainland and your business is affected, we recommend that you migrate the server from the China (Hong Kong) region to a region in the Chinese mainland. For more information, see A timeout error occurs when I connect to a simple application server that is deployed in a region outside the Chinese mainland.

  • Check the monitoring information to see whether the bandwidth of the server is exhausted. A large amount of outbound traffic can cause congestion inside the host, which will result in slow response or even no response to external requests. A large amount of outbound traffic results from the following two reasons:

    • The server receives a large number of requests. We recommend that you increase the bandwidth if the business traffic on the server is large. For more information, see Upgrade a simple application server.

    • The server is attacked by abnormal external packet traffic. We recommend that you clean up abnormal processes and scheduled tasks.

  • Check whether the network of the on-premises device is stable. For more information, see Test network paths when packet loss or connection failures occur after the ping command is run.

  • If you have overdue payments for the server, access to the server is affected. You can renew the server. For more information, see the "Renew a simple application server" section of the Upgrade and renew a simple application server topic.