This topic provides answers to some frequently asked questions (FAQ) about IoT Platform instances.
For more information about IoT Platform instances, see Overview.
What do I do if I cannot find the instance that I purchased?
Issue
After you activate IoT Platform or purchase an Enterprise Edition instance, you cannot find a public instance or the Enterprise Edition instance that you purchased.
Cause
The region that you selected in the IoT Platform console is different from the region in which the instance resides. The following table describes the regions in which public instances and Enterprise Edition instances are available.
Instance type
Supported regions
Public instances of the previous version
China (Shanghai), Germany (Frankfurt), US (Silicon Valley), US (Virginia), Singapore, and Japan (Tokyo)
Public instances of the new version
Enterprise Edition instances
China (Shanghai), China (Beijing), China (Shenzhen), Germany (Frankfurt), US (Silicon Valley), US (Virginia), Singapore, and Japan (Tokyo)
The homepage of the IoT Platform console is not refreshed after you purchase an instance.
If you go to the tab of an environment to which the instance that you purchased does not belong, including the Production environment and Test environment tabs, you cannot find the instance.
Solution
To find an instance in a region in which Enterprise Edition instances are available, perform the following steps:
Log on to the IoT Platform console.
In the upper-left corner, select the region in which the instance resides.
Go to the All environment tab of the Overview and find the instance.
The most recently purchased Enterprise Edition instance is displayed at the top of the instance list.
How do I obtain the ID of an instance?
Issue
If you want to configure a device SDK, IoT Platform SDK, or Advanced Message Queuing Protocol (AMQP) SDK, the ID of an Enterprise Edition instance or a public instance of the new version is required.
Solution
Log on to the IoT Platform console. In the upper-left corner, select the region in which the instance that you want to manage resides.
On the Overview tab, find the instance whose ID you want to obtain and view the ID of the instance.
ImportantIf you log on to the IoT Platform console of the previous version, no instance ID is displayed on the Public Instance card of the Overview tab.
If you use an IoT Platform SDK to call API operations, you do not need to specify an ID for the IotInstanceId parameter. Remove the
IotInstanceId
parameter from the request parameters.If you want to connect a device or an AMQP client to IoT Platform, you must specify an empty string. Example:
iotInstanceId = ""
.
Why am I unable to find devices and the related migration information on the Migration Details page after I perform phased migration?
For more information about how to migrate the resources of an IoT Platform instance, see Overview of instance migration.
Issue
After you perform phased migration, no device information is displayed on the Migration Details page.
Cause
During phased migration, the system copies the data of products and the rules engine, and then migrates specific device data. If device data fails to be migrated because one of the first two steps fails, no device information is displayed on the Migration Details page. This issue does not affect your business.
Solution
Repeat phased migration. For more information, see Step 2: Perform phased migration.