Problem description
When you open the sqlconsolerg page, the following error is reported.
No database information is available. A possible cause is that the DMS server cannot connect to the database.
Cause
To enable you to quickly restart your work after you close the browser, DMS binds the unique identifier of the SQL Console page and the unique identifier of the current database to record the SQL Console and relevant SQL records in the browser. When you open the SQLConsole tab of a database, the system uses the unique identifier of the SQLConsole tab to obtain the unique identifier of the database from the cache of the browser. Then, the system uses the unique identifier of the database to obtain data in the database from the backend. The connectivity error message appears in the following scenarios:
- DMS finds the database at the backend but is unable to connect to the database.
- The database belongs to another DMS tenant to which the current Alibaba Cloud account or RAM user is added. An Alibaba Cloud account or a RAM user can be added to multiple DMS tenants. However, you cannot access resources across DMS tenants.
- The database is deleted.
- The instance to which the database belongs is disabled or deleted.
- Caused by browser cache.
Solution
Alibaba Cloud reminds you that:
- Before you perform operations that may cause risks, such as modifying instance configurations or data, we recommend that you check the disaster recovery and fault tolerance capabilities of the instances to ensure data security.
- You can modify the configurations and data of instances including but not limited to Elastic Compute Service (ECS) and Relational Database Service (RDS) instances. Before the modification, we recommend that you create snapshots or enable RDS log backup.
- If you have authorized or submitted sensitive information such as the logon account and password in the Alibaba Cloud Management Console, we recommend that you modify such information in a timely manner.
If the preceding error is returned, close the error page and reopen the SQL Console of the destination database. If the problem persists, select one of the following solutions based on the actual situation and make sure that the instance connection is correct. Then, reopen the SQL Console of the destination database.
- Check the connectivity of the target database. For example, to check the whitelist or modify database accounts, see the following documents:
- To check whether the tenant is shifted, see view tenant information. If the tenant is shifted, switch back to the original account information.
- If the destination database is deleted, confirm the information with relevant personnel.
- See disable or enable instances to check whether an instance has been disabled or deleted from the DMS console. If an instance has been disabled, enable it or delete it. For more information, see delete an instance.
- Clear the browser cache and reopen the SQL Console page of the target database.
Related topic
Application scope
- Data Management