This topic describes how to fix errors for an abnormal backup schedule in Database Backup (DBS).
Problem description
A backup schedule is abnormal on the Backup Schedules page of the DBS console.
Cause
If your backup schedule is abnormal, at least one task becomes abnormal in the backup schedule. In most cases, the abnormal task may be a full backup task or an incremental backup task. The abnormal task may also be a task of other types.
If an error occurs in a task, DBS does not directly start the abnormal task. This prevents your business from being affected.
To ensure that your business can run as expected, we recommend that you troubleshoot the error that occurs in your backup schedule at the earliest opportunity. If the error persists after you troubleshoot the error by referring to the solutions provided in this topic, join the DingTalk group whose ID is 35585947 and contact technical support.
Solution
The following table describes the solutions provided by DBS to help you fix errors for abnormal tasks in a backup schedule.
Scenario and solution | Usage notes |
If you have identified the cause of the error that occurs in an abnormal task and fixed the error, you can restart the abnormal task. For example, if a backup error is caused by the shutdown of the source instance, you can restart the backup task after you start the source instance. |
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If you have identified the cause of the error that occurs in an abnormal task and fixed the error, you can ignore the error. For example, if a backup error is caused by the shutdown of the source instance or service exceptions, and the source instance is started or services become normal, you can ignore the error. The backup will be performed in the next backup window. | If the error is fixed, the state of the abnormal task changes to Completed after you ignore the error. In this case, if only one abnormal task exists in your backup schedule, the state of the backup schedule changes to Running. If the backup schedule is still abnormal, check whether other abnormal tasks exist in the backup schedule. |
If you cannot determine the cause of the error that occurs in an abnormal task or the solution to the error, you can move the pointer over the exclamation point (!) icon to view the error information. Then, search for the error that you want to fix in the Common Errors and Troubleshooting topic. | If the error is not described in the "Common Errors and Troubleshooting" topic, or your issue persists after you refer to the solutions provided in the topic, join the DingTalk group whose ID is 35585947 and contact technical support. |
Procedure
Log on to the DBS console. In the left-side navigation pane, click Backup Schedules. On the Backup Schedules page, find the abnormal backup schedule and click Rectify in the Status column. You are navigated to the task list page based on the type of the abnormal task in the backup schedule.
If the abnormal task is a full backup task, you are navigated to the Full Data page. If the abnormal task is an incremental backup task, you are navigated to the Incremental Data page.
Select a solution based on the abnormal task and your business requirements.
If you want to restart an abnormal backup task, find the task and click Restart Backup in the Status column.
NoteIf you perform full backup, evaluate the impact of full backup on the source database before you restart the abnormal backup task. We recommend that you restart the abnormal backup task during off-peak hours.
If you want to ignore errors for an abnormal task, find the task and click Ignore Error in the Status column.
If you want to fix errors for an abnormal full backup task, find the task and move the pointer over the exclamation point (!) icon in the Status column to view the error information. Then, click View Exception Fixing Suggestions in the Status column. If you want to fix errors for an abnormal incremental backup task, click View Incremental Exception Fixing Suggestions in the upper part of the Incremental Data page. You are navigated to the Common Errors and Troubleshooting topic. Search for the error that you want to fix in the "Common Errors and Troubleshooting" topic and try to fix the error based on the solutions provided in the topic.
NoteIf the error that you want to fix is not described in the "Common Errors and Troubleshooting" topic, the error may be caused by an abnormal task of other types. In this case, join the DingTalk group whose ID is 35585947 and contact technical support.