Problem description
A large number of errors or timeouts occur during the stress testing when the backend load is small.
Causes
In most cases, the bottleneck of the outermost service layer (network access layer) or the triggering of some thresholds results in the preceding issue.
Solutions
Monitor and observe products that use the network access layer (network ingress). The following content describes the common product types that use the network access layer and the corresponding precautions:
Business that uses Server Load Balancer (SLB) instances
If an SLB instance is the outermost service layer and the used API adopts the HTTPS protocol, or you enable the layer 7 session persistence feature, some 503 errors occur during the stress testing, and the backend does not have relevant traffic and logs. the single IP address of the SLB instance may be throttled. For more information, see 503 (Service Unavailable).
Business that uses Anti-DDoS IP addresses and Web Application Firewall (WAF) instances
Some stress testing characteristics are similar to those of Challenge Collapsar (CC) and DDoS attacks. This way, the corresponding product protection policies are triggered, which causes inaccurate stress testing results and stress testing failures. After you evaluate the impacts on your business, we recommend that you make the temporary disablement or allow the stress testing traffic of Performance Testing Service (PTS). For more information, see FAQ overview and What can I do if the stress testing traffic of PTS cannot access Web applications due to a specified security policy?
Business that uses Content Delivery Network (CDN) points of presence (POPs) or Edge Security Acceleration (ESA) POPs
If your business approximately reaches or surpasses its existing peak performance level, submit a ticket to report CDN POPs and ESA POPs.