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:What do I do if objects are frozen and inaccessible?

Last Updated:Mar 08, 2024

Problem description

Objects in Object Storage Service (OSS) are frozen and cannot be accessed due to one of the following reasons:

  • The storage class of the objects is Archive, Cold, or Deep Cold Archive.

  • The objects have compliance issues.

Causes

Objects in OSS are in the frozen state in the following scenarios:

  • The objects are stored in an Archive or Cold Archive bucket and inherit the storage class of the bucket.

  • The Archive or Cold Archive storage class is specified for the objects during the upload.

  • A lifecycle rule is configured to convert the storage class of the objects to Archive or Cold Archive.

  • The objects are reported and confirmed to have content violations.

Solutions

Perform the following steps to troubleshoot the error:

  1. Log on to the Message Center console. In the left-side navigation pane, choose Internal Messages > All Messages. On the page that appears, click Security to check if you have compliance violation messages.

    • If the objects are frozen due to non-compliant content, check URLs that contain non-compliant information at Harmful Internet Information, remotely log on to your server, and delete all non-compliant website content, including but not limited to violations clarified in the compliance violation messages. After you delete non-compliant content, you need to apply for unblocking.

    • If no violation messages exist, proceed to the next step.

  2. Log on to the OSS console. In the left-side navigation pane, click Buckets. On the page that appears, click the name of the bucket that stores the frozen objects. On the page that appears, choose Object Management > Objects and view the Storage Class of the objects. If the objects are in the Archive or Cold Archive storage class, perform the following steps:

    1. Call the RestoreObject operation to restore Archive or Cold Archive objects. For more information, see Restore objects.

      Note
      • It takes 1 minute to restore an Archive object. The time required to restore a Cold Archive object depends on the object size and the restoration priority.

      • Data retrieval fees are generated when you restore Archive or Cold Archive objects. For more information, see Data processing fees.

    2. (Optional) Convert the storage class of the objects to Standard or Infrequent Access (IA). For more information, see Convert storage classes.