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Elastic Compute Service:When you ping the internet address of a Windows instance, the system prompts "general fault"

Last Updated:Dec 15, 2020

Disclaimer: This article may contain information about third-party products. Such information is for reference only. Alibaba Cloud does not make any guarantee, express or implied, with respect to the performance and reliability of third-party products, as well as potential impacts of operations on the products.

 

Problem description

This article describes how to resolve a common fault when you ping an internet address of a Windows instance.

 

Possible cause

This problem is usually caused by the following reasons.

  • A third-party anti-virus or security protection software is installed on the operating system.
  • The operating system TCP/IP protocol stack is damaged, such as registry damage.
  • An incorrect IP address security policy is set in the group policy.
  • The Routing and Remote access functions are enabled on the server, but the configuration is not properly adjusted.

 

Solution

Alibaba Cloud reminds you that:

  • Before you perform operations that may cause risks, such as modifying instance configurations or data, we recommend that you check the disaster recovery and fault tolerance capabilities of the instances to ensure data security.
  • If you modify the configurations and data of instances including but not limited to ECS and RDS instances, we recommend that you create snapshots or enable RDS log backup.
  • If you have authorized or submitted security information such as the logon account and password in the Alibaba Cloud Management console, we recommend that you modify such information in a timely manner.

This article mainly introduces the following contents.

 

Check third-party antivirus software

If a third-party anti-virus or security protection software is installed, uninstall the third-party software.

 

Check network interface controller configuration information

Run the ipconfig/all or routeprint command to check the IP address configuration. If any problem is found, reset the TCP/IP protocol stack. For more information, see the following link.

 

Check whether IP security policies are set

  1. Log on to a Windows instance and select start > Run the secpol.msc command to open the local security settings page.
  2. Click IP security policies on your local computer, right-click the safe click property in safe property interface to view rules. As you can see, the IP address security policy is in the assignment state. The rule is first pass and then deny). If you are not familiar with this policy, configuration errors may occur.
  3. Right-click safe and then click not assigned.
  4. Select start > Management tools > Routing and Remote Access, disable Local Routing and Remote Access, or click stop in all tasks.
  5. Select start > Run. Run the services.msc command to open the service window, find the "Routing and Remote Accesss" service in the list, and confirm that the service is disabled.

 

Application scope

  • ECS