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Elastic Compute Service:What do I do if a Windows instance stutters due to excessive memory reserved for hardware?

Last Updated:Jul 26, 2024

This topic describes how to resolve the issue that a Windows Elastic Compute Service (ECS) instance stutters due to excessive memory reserved for hardware.

Problem description

A Windows ECS instance stutters or slowly responds.

Causes

If licenses are improperly configured in the registry of the Windows operating system and the instance type of the Windows ECS instance is changed to an instance type that has a much smaller or larger memory size, the instance cannot be activated as expected and a large amount of memory is locked or reserved for hardware. As a result, the memory load of the instance greatly increases, and the instance stutters or slowly responds.

Note

To view the memory usage of the Windows ECS instance, including the amount of memory reserved for hardware, you can open Task Manager on the instance, click the Performance tab, and then click Memory in the left-side navigation pane.

Solution

To resolve the preceding issue, you can reset the activation status of Key Management Service (KMS) for the Windows ECS instance. Perform the following steps.

Important

Before you perform high-risk operations, such as modifying the configurations or data of an ECS instance, make sure that the instance has disaster recovery and fault tolerance capabilities. To ensure data security, we recommend that you create snapshots for disks attached to the ECS instance to back up data. For more information, see Create a snapshot for a disk.

  1. Connect to the Windows ECS instance.

    For more information, see Connection method overview.

  2. Open a command prompt window as an administrator.

  3. Clear KMS activation settings.

    1. Run the following command to clear the KMS server settings:

      slmgr.vbs /ckms
    2. Run the following command to uninstall the current product key:

      slmgr.vbs -upk
    3. Run the following command to reset the licensing status of the Windows ECS instance:

      slmgr.vbs -rearm

      If you are prompted to restart the system as shown in the following figure, restart the Windows ECS instance for the changes to take effect.

      image

    4. Restart the Windows ECS instance for the changes to take effect.

      For more information, see Restart an instance.

  4. Reactivate KMS.

    1. Identify the correct KMS client product key for the Windows operating system version of the ECS instance.

      For information about KMS client product keys, see Key Management Services (KMS) client activation and product keys.

    2. Run the following commands to reactivate KMS:

      slmgr.vbs /ipk your_kms_key # Replace your_kms_key with the KMS client product key that you obtained in Step 4.a. 
      slmgr -skms kms.cloud.aliyuncs.com # Change the KMS server domain name to the Alibaba Cloud KMS server domain name. 
      slmgr.vbs /ato
  5. Restart the Windows ECS instance for the changes to take effect.

    For more information, see Restart an instance.