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Elastic Compute Service:What do I do if Windows Update is stuck at 0% on an ECS instance when the Windows operating system of the instance is updated?

Last Updated:Jul 26, 2024

This topic describes the cause of and solution to the issue that Windows Update is stuck at 0% on an Elastic Compute Service (ECS) instance when the Windows operating system of the instance is updated.

Problem description

Windows Update is stuck at 0% on an ECS instance when the Windows operating system of the instance is updated. When you use the instance health diagnostics feature to diagnose the issue, an error message appears indicating that Windows Update fails because the mpssvc process that corresponds to the Windows Defender Firewall service of the instance is not started.

Cause

The preceding issue may occur when the mpssvc process that corresponds to the Windows Defender Firewall service is not started.

Solution

Modify the registry and start the Windows Defender Firewall service.

  1. Connect to the Windows instance.

    For more information, see Connect to a Windows instance by using a password or key.

  2. Check the status of the Windows Defender Firewall service.

    1. In the lower-left corner of the desktop, click the image.png icon and choose Windows System > Control Panel.

    2. In the Control Panel window, click System and Security. In the window that appears, click Allow an app through Windows Firewall in the Windows Defender Firewall section.

      If the Windows Defender Firewall can't change some of your settings. Error code 0x80070422 error message appears, the preceding issue occurred because the Windows Defender Firewall service is not started.

  3. Modify the registry of the Windows Defender Firewall service.

    1. Click the Start icon, choose Windows System > Run, enter regedit in the Run dialog box, and then click OK to open the Registry Editor window.

    2. In the address bar, enter the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\mpssvc path and press the Enter key. Then, find the Start parameter.

    3. Right-click the Start parameter and select Modify...

      image.png

    4. In the dialog box that appears, set the Base parameter to Decimal and the Value data parameter to 2 and then click OK.

      image.png

  4. Start the Windows Defender Firewall service.

    1. Click the Start icon, choose Windows System > Run, enter services.msc in the Run dialog box, and then click OK.

    2. In the Services window, find the Windows Defender Firewall service and start the service.

  5. Restart the instance to allow the preceding changes to take effect.

    For more information, see Restart an instance.

    Warning

    The restart operation stops the instance for a short period of time and may interrupt services that are running on the instance. We recommend that you restart the instance during off-peak hours.

  6. Re-update the Windows operating system. If the Windows operating system is updated, the preceding issue is resolved.