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Elastic Compute Service:Resolve the issue that data disks on a Windows instance cannot be viewed

Last Updated:Jun 05, 2023

This topic describes the cause of the following issue and how to resolve the issue: You cannot view a data disk on an Elastic Compute Service (ECS) Windows instance.

Problem description

You cannot view a data disk on a Windows instance.

Causes

The issue occurs because of the following reasons:

Solutions

To resolve the issue, perform the following operations based on the cause of the issue.

The data disk is listed as Foreign or Offline

After you upgrade the Windows operating system of an instance to a more recent version, you may be unable to view a data disk on the instance. In the Run dialog box, run the diskmgmt.msc command to open Disk Management. In the Disk Management window, the data disk may be listed as Foreign or Offline. Perform one of the following operations to repair the data disk:

  • If the disk is listed as Foreign, right-click the disk in the Disk Management window, select Import Foreign Disks, and then click OK.

  • If the disk is listed as Offline, right-click the disk in the Disk Management window and select Online.

    Note

    After you select Online, you may receive the error message "The disk is offline because it has a signature collision with another disk that is online." This message indicates that an error occurred when the disk was automatically mounted to the Windows instance. You can take the disk offline and then bring the disk back online. Windows attempts to regenerate a signature for the disk when you bring the disk online.

The disk drive is disabled

After you start an instance that runs Windows 2019, you may be unable to view a data disk on the instance because the disk drive is disabled. Perform the following steps to enable the disk drive:

  1. Open Computer Management. In the left-side navigation pane of the Computer Management window, choose System Tools > Device Manager. In the right pane, expand Disk drives.

  2. Right-click the disk drive that is disabled and select Enable drive.

    The data disk is displayed in the Disk Management window.

The data disk is new and is not partitioned or formatted

Warning

Disk partitioning and formatting are high-risk operations. Proceed with caution. Before you perform the operations on data disks that are attached to ECS instances, create snapshots of the disks to prevent data loss. For information about how to create a snapshot of a disk, see Create a snapshot of a disk.

If the data disk is new and is not partitioned or formatted, the disk is not displayed in the Windows operating system of the instance. The partition format of the new disk is RAW. The Windows operating system cannot recognize files in the RAW format. Perform the operations that are described in Initialize a data disk up to 2 TiB in size on a Windows instance to initialize the data disk.

No drive letter is assigned to the data disk

If a drive letter is not assigned to a data disk, the disk cannot be displayed. In the Run dialog box, run the diskmgmt.msc command to open Disk Management. The data disk is recognized by the operating system and a drive letter is not assigned to the disk. Perform the following steps to resolve the issue:

Note

In this example, Windows 2008 is used. The operations that you must perform may vary based on the operating system.

  1. In the Disk Management window, right-click the partition that you want to manage for the data disk and select Change Drive Letter and Paths.

  2. In the dialog box that appears, click Change.

  3. In the Change Drive Letter or Path dialog box, select a drive letter. If you cannot find the drive letter that you want to assign to the data disk in the Assign the following drive letter drop-down list, check whether the drive letter is being used by another disk or an optical drive.

    Note

    If the data disk is being used by the operating system, you must restart the instance for the change to take effect. We recommend that you restart the instance during off-peak hours.

An error occurs when the data disk is attached to an instance that runs Windows 2012

After you attach a data disk to an instance that runs Windows Server 2012, the disk is not displayed in the Disk Management window and an error occurs. The error is caused by a system enumeration exception. Perform the following operations to repair the data disk:

Important

Before you perform the operations, create a snapshot of the data disk to prevent data loss. For more information, see Create a snapshot of a disk.

  1. Open the Windows PowerShell command window and run the winrm quickconfig command.

  2. At the confirmation prompts, enter y.

  3. After the issue is resolved, open Disk Management and check whether the data disk is displayed.

The instance is in safe mode

When the Windows instance is in safe mode, the data disk may not be displayed because the disks or drives of the instance are not loaded. You can view the data disk after the instance exits safe mode. Perform the following steps:

  1. Right-click the Start icon and select Run. In the Run dialog box, enter msconfig and click OK.

  2. In the System Configuration dialog box, click the Boot tab and clear Safe boot in the Boot options section.

  3. Click OK to exit safe mode.