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CloudMonitor:How do I fix the issue that the API quota has been exhausted or is about to be exhausted?

Last Updated:Oct 29, 2024

The free quota of API calls for metric data query is one million calls per month. After the free quota is used up, throttling is triggered. This topic describes the issue that the free quota of API calls for metric data query is used up and provides related causes and solutions.

Issue

  • When the number of API calls used for metric data query per month reaches 1 million, you receive emails or text messages stating that the quota has been used up on the first and fourth days, and throttling is triggered on the fifth day.

  • If user api quota limit appears in the response after you call an API operation, throttling has been triggered.

Causes

The quota of API calls for metric data query is consumed in the following scenarios:

Solutions

  • We recommend that you resolve the issue by performing the following operations:

    • Reduce the frequency at which you call API operations. Call API operations at an interval of 5 minutes instead of 1 minute.

    • Reduce the number of resources queried by calling an API at a time.

      You can query up to 50 resources at a time. For example, when you call the DescribeMetricLast operation, set the request parameter Dimensions to [{instanceId:***},{instanceId:***},{instanceId:***}].

    • Activate CloudMonitor Basic (pay-as-you-go).

      For more information, see Enable the pay-as-you-go billing method.

    • Use the cloud monitoring exporter feature provided by Hybrid Cloud Monitoring. The cloud monitoring exporter feature provides low cost, low latency, and high reliability.

      For more information, see Export monitoring data in real time.

  • If the quota is used up because you use the Grafana plug-ins of CloudMonitor, we recommend that you use the dashboards of Hybrid Cloud Monitoring.

    For more information, see Manage dashboards.