This topic describes the cause of and solution to the issue that the value of the Status parameter of a monitoring item is No data.
Problem description
An alert rule is configured. However, in the Alert Rules Associated with Resource panel, the value in the Status column is No data.
Possible cause
The minor version of your ApsaraMQ for Kafka instance is outdated.
Solution
Log on to the ApsaraMQ for Kafka console.
In the Resource Distribution section of the Overview page, select the region where the ApsaraMQ for Kafka instance that you want to manage resides.
On the Instances page, click the name of the instance that you want to manage.
On the Instance Details page, click the Instance Information tab.
In the Basic Information section, click Minor Version Update next to the Minor Version parameter.
In the panel that appears, perform the following operations:
Read the content in the Read Before Upgrade section.
Enter your name in the Emergency Contact field.
Enter your emergency phone number in the Emergency Contact Number field.
Enter the upgrade time in the Started At field.
Click OK.