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云备份:本地备份相关问题

更新时间:Dec 17, 2024

本文为您介绍如何解决在备份本地文件时遇到的问题。

如何修改文件备份客户端的登录端口?

安装备份文件客户端时,客户端登录端口默认为8011。如果8011端口已被其他应用占用,您可以在安装客户端时将文件备份客户端的登录端口修改成指定端口。

  • Windows:

    如果需要备份文件的服务器或虚拟机是Windows系统,按照以下操作安装客户端并指定登录客户端的端口号:

    1. 将文件备份客户端下载到需要备份文件的服务器或虚拟机上。

    2. 解压客户端安装包。

    3. 打开终端CMD。

    4. 在终端进入解压程序所在的目录。

    5. 输入安装包执行文件并添加参数 /p=指定端口号,例如hbr-install-1.5.2-windows-amd64.exe /p=8022,回车后根据提示完成客户端安装。

      安装成功后,在浏览器中输入http://localhost:指定端口回车即可开始激活文件客户端。

  • Linux:

    如果需要备份文件的服务器或虚拟机是Linux系统,按照以下操作安装客户端并指定登录客户端的端口号:

    1. 将文件备份客户端下载到需要备份文件的服务器或虚拟机上

    2. 将下载的文件客户端安装包直接解压到特定目录,运行./setup -p 指定端口号开启云备份服务。例如,您希望将文件备份客户端的登录端口设置为8022,运行./setup -p 8022即可。

安装成功后,在浏览器中输入http://localhost:指定端口回车即可开始激活登录客户端。

备份本地Windows文件失败,错误报告显示“Access is denied”

  • 问题现象

    使用文件备份客户端备份本地Windows文件,备份失败,且显示错误数。

    单击错误数栏中的下载图标下载错误报告,报告中显示“Access is denied”。

  • 解决方法

    这种情况是由于文件没有System权限导致,为备份失败的文件添加System权限即可。

云备份客户端在Windows 2016上安装失败,该如何解决?

使用Windows 2016自带工具解压客户端安装包后,右键单击解压后的安装文件,选择属性,勾选解除锁定,然后单击确定后即可正常安装。

如何重新激活文件客户端?

使用本地服务器文件(旧版文件)功能时,需要安装客户端。若激活文件客户端失败,客户端在控制台显示为待激活状态。您可以按照以下方式重新激活客户端。

方式一:在控制台重新激活客户端

  1. 登录云备份Cloud Backup控制台

  2. 在左侧导航栏,选择备份 > 本地文件备份在顶部菜单栏左上角,选择所在地域。在本地文件备份页面,单击旧版

    image

  3. 在客户端列表中找到待激活的客户端。在目标客户端的操作列,选择更多 > 激活客户端

  4. 添加客户端面板的激活客户端页签中,按照以下说明填写激活客户端的所需参数。

    参数

    描述

    客户端IP地址

    安装备份客户端所在服务器或虚机的IP地址。

    说明

    当前浏览器必须能够连接到此IP地址。

    AccessKey Id

    设置您的AccessKey ID。如何获取,请参见获取AccessKey

    AccessKey Secret

    设置您的AccessKey Secret。如何获取,请参见获取AccessKey

    创建客户端登录密码

    为客户端Web管理界面设置登录密码。登录密码至少为6位。

    确认密码

    再次输入密码。

    显示高级选项

    您可以通过代理方式配置管控网络信息、消息通道网络信息及其网络类型。网络的代理信息包括用户名、密码、IP地址和端口。

    • 管控网络代理:管控网络的代理信息。

    • 数据网络代理:数据网络的代理信息。

    • 管控网络类型:管控网络的网络类型,包括自动、VPC和公网。

    • 消息通道网络类型:消息通道网络的网络类型,包括自动、VPC和公网。

  5. 单击激活客户端

    浏览器会自动弹出文件客户端操作页面。您可以在文件客户端进行备份。

方式二:在客户端Web页面重新激活客户端

  1. 登录云备份Cloud Backup控制台

  2. 在左侧导航栏,选择备份 > 本地文件备份在顶部菜单栏左上角,选择所在地域。在本地文件备份页面,单击旧版

    image

  3. 在客户端列表中找到待激活的客户端。在目标客户端的操作栏,选择更多 > 下载证书然后保存下载的证书。

  4. 登录浏览器,访问http://localhost:8011

  5. 初始化注册界面,然后按照以下说明配置参数。

    说明
    • 如果是通过中转机来进行备份操作,需要把localhost换成需要备份的服务器或虚拟机的IP地址。

    • 文件客户端的登录端口号默认为8011,若目标服务器或虚拟机上的8011端口已经被其他程序占用,您可以修改备份客户端的登录端口号。具体操作,请参见如何修改文件备份客户端的登录端口?

    参数

    说明

    证书文件

    选择在控制台下载的证书作为上传的Token。每个证书的使用周期为2天,超过此周期,需要下载新的证书来注册客户端。

    AccessKey Id

    设置您的AccessKey ID。如何获取,请参见获取AccessKey

    AccessKey Secret

    设置您的AccessKey Secret。如何获取,请参见获取AccessKey

    备份数据网络

    • 内网:需要备份的机器使用阿里云专有网络(VPC),且和备份仓库在同一个地域时选择此项。

    • 公网:通过公网进行备份。

    显示高级选项

    您可以通过代理方式配置管控网络信息、消息通道网络信息及其网络类型。网络的代理信息包括用户名、密码、IP地址和端口。

    • 管控网络代理:管控网络的代理信息。

    • 数据网络代理:数据网络的代理信息。

    • 管控网络类型:管控网络的网络类型,包括自动、VPC和公网。

    • 消息通道网络类型:消息通道网络的网络类型,包括自动、VPC和公网。

    密码

    为客户端Web管理界面设置登录密码。登录密码至少为6位。

    确认密码

    再次输入密码。

    用登录密码加密AK

    如果使用登录密码来加密,每次重启后都需要手动输入。

  6. 单击注册,激活客户端。

备份本地文件失败如何解决?

  • 问题现象

    windows系统上使用文件备份客户端备份本地文件时,备份失败。错误码为0xc0000142。

  • 解决方法

    备份本地文件失败的原因在于客户端程序hbrclient.exe启动备份工作进程ids.exe时失败。

    1. 原因通常源于您安装的杀毒软件错误地删除了ids.exe文件。为解决此问题,请您核实安全软件的查杀日志,并将hbrclient.exe与ids.exe这两个客户端程序添加到软件的信任列表或白名单中,以确保它们能正常运行。

    2. 由于本地安全策略的限制,系统用户无法启动ids.exe程序;为确保顺利运行,建议使用管理员(Administrator)账户权限来登录。具体操作,请参见管理员账号登录

本地文件备份页面显示的IP地址是本地的IP吗?

本地文件备份页面显示的IP地址可能并非您实际使用的正确IP,目前云备份不支持自动识别并显示正确的IP地址。IP仅用于展示,不会影响您的备份业务。

报错“数据写入到存储库失败,请检查防火墙是否会阻拦域名或端口的连接,并保证足够的网络传输带宽。”

  • 问题现象

    客户端日志出现“数据写入到存储库失败,请检查防火墙是否会阻拦域名或端口的连接,并保证足够的网络传输带宽。file_path: client.PutObject: Put *: net/http: timeout awaiting response headers”错误。

  • 问题原因

    网络行为检测工具检测到非法内容,限制了对应请求。

  • 解决方案

    1. 排除指定文件(即排除非法内容文件)。

      1. 登录云备份Cloud Backup控制台

      2. 单击备份 > 本地文件备份,选择所在地域,然后单击新版。在备份计划页签,选择对应的备份计划,单击操作栏的编辑

        image

      3. 配置备份计划页面

        1. 勾选高级规则模式

        2. 备份目录规则:选择指定目录

        3. 备份文件路径:填入备份文件路径。备份路径规则可参考控制台。

        4. 备份文件规则:选择排除指定文件

        5. 输入文件列表:填入排除指定文件的路径,路径为日志里的file_path。路径规则可参考控制台。

        6. 单击确定

        image

    2. 请检查安全软件的查杀日志,并将 hbrclient.exeids.exe 这两个程序添加到信任列表或白名单中,以确保它们能够正常运行。

安装windows文件客户端失败,提示“初始化客户端失败,请检查输入的参数是否正确。”

请先确认是否已安装过该客户端。如果已安装,请检查系统中是否存在如下的注册表项残留。若发现有残留项,建议先将其删除,然后再重新进行安装。

HKLM:\\SYSTEM\\CurrentControlSet\\services\\eventlog\\Application\\hbrclient

HKLM:\\SYSTEM\\CurrentControlSet\\services\\eventlog\\Application\\hbrclientupdater

HKLM:\\SOFTWARE\\Alibaba, Inc.\\Aliyun Hybrid Backup Service Client