問題描述
阿里雲Server Load Balancer的後端ECS執行個體在沒有用戶端訪問時,會頻繁收到GET請求,且來源的IP是阿里雲的內網IP,User-Agent顯示為KeepAliveClient。
問題原因
在負載平衡管理主控台建立Server Load Balancer執行個體監聽時,負載平衡監聽協議選擇的TCP和健全狀態檢查協議選擇的HTTP不一致,導致執行個體對後端的健全狀態檢查方法是GET方法,不是HEAD方法。
解決方案
說明
阿里雲提醒您:
如果您對執行個體或資料有修改、變更等風險操作,務必注意執行個體的容災、容錯能力,確保資料安全。
如果您對執行個體(包括但不限於ECS、RDS)等進行配置與資料修改,建議提前建立快照或開啟RDS記錄備份等功能。
如果您在阿里雲平台授權或者提交過登入帳號、密碼等安全資訊,建議您及時修改。
建議您將監聽的協議和健全狀態檢查的通訊協定設定為同一個協議,例如HTTP或HTTPS協議,這種情況下負載平衡就會使用HEAD方法來進行健全狀態檢查了,具體操作請參見方法一。
或者統一改為TCP協議,TCP模式的健全狀態檢查是基於網路層探測,通過發送SYN握手報文來檢測伺服器連接埠是否存活,對後端ECS執行個體負載較小,具體操作請參見方法二。
方法一
建立一個HTTP或HTTPS協議監聽配置,具體配置操作請參見配置健全狀態檢查。
方法二
登入負載平衡管理主控台,選擇目標地區,單擊目標負載平衡的執行個體ID。
單擊監聽,依次單擊修改監聽配置>下一步>下一步,單擊修改。
將健全狀態檢查協議由HTTP修改為TCP,然後依次單擊下一步>提交即可。
適用於
Server Load Balancer