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ApsaraDB RDS:"cannot open user default database.Login failed" is displayed when you log on to the apsaradb RDS for SQL Server instance

更新時間:Apr 13, 2022

Problem description

The following error occurs when you log on to the apsaradb RDS for SQL Server instance.

cannot open user default database.Login failed

Cause

You have deleted the database for which you log on by default under this account, and your logon fails.

Solution

Alibaba Cloud reminds you that:

  • Before you perform operations that may cause risks, such as modifying instance configurations or data, we recommend that you check the disaster recovery and fault tolerance capabilities of the instances to ensure data security.
  • You can modify the configurations and data of instances including but not limited to Elastic Compute Service (ECS) and Relational Database Service (RDS) instances. Before the modification, we recommend that you create snapshots or enable RDS log backup.
  • If you have authorized or submitted sensitive information such as the logon account and password in the Alibaba Cloud Management Console, we recommend that you modify such information in a timely manner.

Log on to the database with another account, or use the SSMS client to specify an account to log on to another database, and then create a default database for this account.

Application scope

  • ApsaraDB RDS for SQL Server