全部產品
Search
文件中心

:OSS檔案處於凍結狀態無法正常訪問

更新時間:Jun 19, 2024

問題描述

阿里雲Object Storage Service中的檔案在以下情境處於冷凍狀態,無法正常訪問。

  • 檔案儲存體類型是Archive Storage、冷Archive Storage或者深度冷Archive Storage。

  • 檔案存在違法違規情況。

問題原因

阿里雲Object Storage Service中的檔案處於凍結狀態有以下幾種情況:

  • 在Object Storage Service中,如果Bucket的儲存類型是Archive Storage或者冷Archive Storage時,預設存放到該Bucket的檔案都是凍結狀態。

  • 上傳檔案時設定了檔案儲存體類型為Archive Storage或者冷Archive Storage,也會導致檔案出現凍結狀態。

  • 通過生命週期將其他類型檔案轉化成Archive Storage或者冷Archive Storage後,檔案會出現凍結狀態。

  • 檔案被舉報,存在違法違規情況,檔案為私人狀態。

解決方案

當您的OSS資源處於凍結狀態時,請參見以下操作進行排查處理:

  1. 開啟訊息中心,然後單擊安全訊息頁簽,查看是否存在違規通知。

    • 如果因安全原因被凍結,請您到互連網有害資訊頁面查看涉及違法違規的URL資訊,根據系統的提醒,將網站違法檔案、違法頁面進行徹底整改刪除(包括但不限於我們通知的內容)。您需要遠程進入您的伺服器,根據URL路徑找到所有違法的檔案並刪除。刪除違法檔案後,您需要申請解除屏蔽。

    • 如果不存在違規通知,請繼續執行下一步。

  2. 登入Object Storage Service控制台,單擊Bucket列表,然後單擊目標Bucket名稱。選擇檔案管理>檔案清單,查看檔案儲存類型。如果檔案類型為Archive Storage或冷Archive Storage類型,請執行以下操作:

    1. 您在訪問Archive Storage或冷Archive Storage類型的檔案(Object)之前,需要先通過RestoreObject介面解凍檔案。更多資訊,請參見解凍檔案。解凍後再將檔案轉換為標準儲存或者低頻儲存。

      說明
      • Archive Storage解凍時間需要1分鐘,冷Archive Storage解凍時間根據資料大小和選擇的解凍模式決定。

      • 解凍Archive Storage和冷Archive Storage類型檔案會產生資料取回費用。更多資訊,請參見資料處理費用

    2. 解凍後如需要將檔案轉換為標準儲存或者低頻儲存,請參見OSS儲存類型轉換