本文介紹物聯網平台執行個體相關的常見問題。
有關物聯網平台執行個體的詳細說明,請參見執行個體概述。
如何尋找到執行個體
問題描述
開通物聯網平台或購買物聯網平台企業版執行個體後,在物聯網平台控制台,找不到公用執行個體或已購買的企業版執行個體。
可能原因
在物聯網平台控制台選擇的地區不是執行個體所在的地區。公用執行個體和企業版執行個體支援的地區如下表所示。
執行個體
支援的地區
公用執行個體
華東2(上海)、德國(法蘭克福)、美國(矽谷)、美國(維吉尼亞)、新加坡、日本(東京)
企業版執行個體
華東2(上海)、華北2(北京)、華南1(深圳)、德國(法蘭克福)、美國(矽谷)、美國(維吉尼亞)、新加坡、日本(東京)
購買執行個體後,未重新整理物聯網平台控制台頁面。
當前頁面為生產環境或測試環境頁簽,目標執行個體不在當前環境中。
解決方案
對於開通企業版執行個體服務的地區,請參考以下步驟尋找執行個體。
登入物聯網平台控制台。
在頁面左上方,選擇目標執行個體所在的地區。
在執行個體概覽頁簽的全部環境頁簽,尋找目標執行個體。
新購買的企業版執行個體,在執行個體列表的首位顯示。
如何擷取到執行個體ID
問題描述
對於企業版執行個體和新版公用執行個體,開發裝置端SDK、物聯網平台雲端SDK和AMQP SDK時,會使用執行個體ID。
解決方案
在物聯網平台控制台頁面左上方,選擇目標執行個體所在的地區。
在執行個體概覽頁簽下方的執行個體列表中,找到當前使用的執行個體,查看ID值。
重要舊版公用執行個體地區不顯示具體ID值:
使用物聯網平台的雲端SDK調用API時,無需傳入執行個體ID(IotInstanceId),請刪除
IotInstanceId
相關的請求代碼。接入裝置和AMQP用戶端時,需傳入空值,例如
iotInstanceId = ""
。
設定執行個體環境有什麼用,設定生產環境和正式環境後對執行個體ID有影響嗎?
物聯網平台基於執行個體管理和營運裝置,設定執行個體環境可標識執行個體下裝置的所屬環境,進而區分和管理不同環境下接入物聯網平台的裝置。
修改執行個體環境對執行個體ID沒有影響:開通新版公用執行個體或購買企業版執行個體成功後,對應的執行個體ID就固定不變了。
物聯網平台執行個體支援擴容嗎?
新版公用執行個體:不支援擴容,固定規格不滿足業務資源需求,可將公用執行個體升級為企業版執行個體。具體操作,請參見公用執行個體升級為企業版執行個體。
企業版執行個體:已購買規格不滿足業務資源需求,可進行執行個體升配。具體操作,請參見企業版執行個體升配。
舊版公用執行個體:不支援擴容,如果提示您資源規格不足,需要將新增或存量裝置遷移到物聯網平台企業版執行個體中。
遷移操作的業務影響和系統改造說明,請參見使用前必讀。
物聯網平台新版公用執行個體有時間限制嗎?
目前沒有。
物聯網平台如何將舊版公用執行個體升級為新版公用執行個體?
物聯網平台不支援將舊版公用執行個體升級為新版公用執行個體。
如果需要使用新版公用執行個體,可以重新註冊一個阿里雲帳號,新開通物聯網平台服務使用新版公用執行個體。具體開通操作,請參見開通新版公用執行個體。
新版公用執行個體顯示已凍結怎麼辦?
在物聯網平台控制台的執行個體概覽頁簽,單擊執行個體卡片,可選擇繼續試用公用執行個體。
如何關閉阿里雲物聯網平台新版公用執行個體?
不支援直接關閉新版公用執行個體,如果新版公用執行個體中已接入裝置長期不線上,物聯網平台系統會自動凍結新版公用執行個體。
您也可以將新版公用執行個體升級為企業版執行個體。升級完成後,不支援再回退為公用執行個體。
舊版公用執行個體和企業版執行個體裝置接入網域名稱有什麼區別?
接入網域名稱格式不同。查看接入網域名稱的方法,請參見查看和配置執行個體終端節點資訊(Endpoint)。
同一阿里雲帳號下的不同執行個體,調用雲端SDK的AK、AS相同嗎?
AccessKey ID和AccessKey Secret是帳號維度存取金鑰,阿里雲帳號(主帳號)和RAM使用者的AccessKey不同,但同一阿里雲帳號或RAM使用者下不同執行個體,調用雲端SDK的AccessKey ID和AccessKey Secret是相同的。
有關AccessKey詳細說明,請參見建立AccessKey。有關調用雲端SDK的憑據方案,請參見憑據的安全使用方式情節。
舊版公用執行個體遷移到企業版執行個體,需要注意哪些問題?
使用執行個體遷移裝置需要瞭解的資訊和準備工作,請參見使用前必讀。
舊版公用執行個體遷移到企業版執行個體,會佔用企業版執行個體資源規格嗎?
會。
如果執行個體下裝置數超過了最大的同時線上數,是超過的新的裝置上線不了,還是會擠掉舊的線上裝置?
新的裝置無法上線。
完成灰階遷移後,遷移詳情頁面無裝置及其遷移資訊
有關物聯網平台執行個體遷移的詳細內容,請參見執行個體遷移概述。
問題描述
執行個體遷移任務完成灰階遷移後,在遷移詳情頁面的裝置列表為空白。
可能原因
灰階遷移過程,依次為複製產品資料、複製規則引擎資料和遷移部分裝置資料。若遷移裝置前的步驟出現問題,裝置未遷移,則遷移詳情頁面無裝置資訊。 此時,對於業務無任何影響。
解決方案
重新進行灰階遷移。具體操作,請參見步驟二:灰階遷移。