全部產品
Search
文件中心

Elastic Compute Service:遠程登入Windows執行個體提示“您的憑據不工作”如何處理?

更新時間:Jul 04, 2024

本文介紹如何處理遠程登入Windows執行個體時提示您的憑據不工作問題。

問題描述

使用遠端桌面訪問Windows系統的ECS執行個體時,出現您的憑據不工作錯誤。

可能原因

出現該問題可能有以下原因:

  • 原因1:如果使用VNC可以正常登入ECS執行個體,可能是Windows作業系統內開啟了密碼保護共用功能。您可以通過關閉密碼保護共用來解決,具體操作,請參見關閉密碼保護共用

  • 原因2:配置了強制來賓賬戶訪問,您可以通過關閉來賓賬戶來解決。具體操作,請參見 關閉來賓賬戶訪問

解決方案

方案1:關閉密碼保護共用

  1. 使用VNC方式登入ECS執行個體。

    具體操作,請參見串連方式概述

  2. 選擇控制台 > 所有控制台項 > 網路和共用中心 > 進階共用設定

  3. 密碼保護的共用配置項,選中無密碼保護的共用,然後單擊儲存更改

    儲存更改

方案2:關閉來賓賬戶訪問

  1. 使用VNC方式登入ECS執行個體。

    具體操作,請參見串連方式概述

  2. 以管理員身份運行Windows PowerShell。

  3. 在Windows PowerShell對話方塊,執行如下命令,關閉來賓賬戶訪問。

    Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Control\Lsa" -Name "forceguest" -Value 0 -Force