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Elastic Compute Service:通過遠端桌面連線Windows執行個體提示“沒有遠端桌面授權伺服器可以提供許可證”錯誤怎麼辦?

更新時間:Dec 18, 2024

本文介紹通過遠端桌面連線Windows執行個體提示“沒有遠端桌面授權伺服器可以提供許可證”錯誤的解決方案。

問題描述

使用遠端桌面連線Windows執行個體,輸入正確的使用者名稱和密碼後,無法正常遠端連線,並提示如下錯誤資訊。

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原因分析

Windows Server系統預設支援最多同時兩個遠端桌面連線會話數。如果需要支援大於兩個會話數,或者需要對訪問裝置或使用者進行許可權控制,則需要安裝遠端桌面服務併購買配置RDS CAL(遠端桌面服務用戶端存取使用權證)。

安裝遠端桌面服務後,從第一次串連遠端桌面開始,系統會進入120天的免費試用期。在此期間,使用者可以正常進行遠端桌面連線而無需立即購買RDS CAL,預設不限制遠端桌面連線會話數。當免費試用結束後,必須購買並配置RDS CAL才能繼續正常使用遠端桌面連線,否則將無法建立串連,會出現該錯誤提示。

解決方案

方案一:刪除遠端桌面服務相關的角色

本文以Windows Server 2016作業系統為例,為您介紹如何刪除相關服務角色。

  1. 登入Windows系統的ECS執行個體,具體請參見串連執行個體

  2. 按右鍵開始,然後單擊運行,在對話方塊中輸入servermanager,單擊確定

  3. 伺服器管理員頁面,刪除遠端桌面服務。

    1. 選擇管理 > 刪除角色和功能刪除遠端桌面zh.png

    2. 伺服器選擇頁面,保持選擇預設Windows執行個體,單擊下一步

    3. 伺服器角色頁面,取消勾選遠端桌面服務。在彈出的對話方塊中,單擊刪除功能,然後單擊下一步image

    4. 功能頁面,取消選中遠端伺服器管理工具,然後單擊下一步

    5. 確認頁面,單擊刪除

    6. 結果頁面,查看刪除任務進度。

  4. 等待刪除任務完成後,重啟Windows執行個體。

    • 方式一:在ECS控制台上重啟Windows執行個體,具體操作,請參見重啟執行個體

    • 方式二:在Windows執行個體案頭,按右鍵開始選擇關機或登出 > 重啟

  5. 嘗試使用RDP串連工具或Workbench進行登入。具體操作,請參見使用Workbench工具以RDP協議登入Windows執行個體

方案二:購買並配置相應的RDS CAL進行授權

購買並配置相應的RDS CAL進行授權。具體操作,請參見申請並啟用多使用者RDS CAL許可證