全部產品
Search
文件中心

:Auto Scaling的警示任務顯示資料不足怎麼辦?

更新時間:Feb 28, 2024

Auto Scaling控制台上建立警示任務後,如果出現警示狀態顯示資料不足的現象,請參考本文方案解決。

問題描述

在Auto Scaling控制台上建立警示任務(系統)後,對應的警示狀態顯示資料不足,具體資訊如下所示:

資料不足.png

問題原因

由於Auto Scaling警示任務的監控源來自CloudMonitor資料,上述問題可能是CloudMonitor未採集到對應的Elastic Compute Service資料所導致。

解決方案

  1. 登入ECS管理主控台

  2. 在左側導覽列,選擇部署與彈性 > Auto Scaling

  3. 伸縮組管理頁面,找到待操作的伸縮組,單擊伸縮組ID進入伸縮組詳情頁。

  4. 單擊執行個體列表頁簽,查看並記錄ECS執行個體ID。

    自動建立頁簽下的ECS執行個體為例,如下圖所示:

    ECS執行個體-en.png

  5. 登入CloudMonitor控制台

  6. 在左側導覽列,單擊主機監控

  7. 在搜尋方塊中輸入ECS伺服器的ID,查看CloudMonitor外掛程式是否安裝。

    主機監控.png

    • 如果argusagent狀態顯示為表徵圖3.jpg表徵圖,表示尚未安裝CloudMonitor外掛程式,您需要單擊表徵圖1.jpg表徵圖2.jpg表徵圖自動或手動安裝。具體操作,請參見安裝CloudMonitor外掛程式

    • 如果argusagent狀態顯示為運行中,表示已經安裝CloudMonitor外掛程式,但是查看監控圖表卻沒有監控資料,請繼續執行下一步排查。

  8. 查看CloudMonitor外掛程式狀態是否正常。

    具體操作,請參見查看外掛程式狀態

    說明

    如果CloudMonitor外掛程式狀態異常,建議您重啟該外掛程式,具體操作,請參見重啟CloudMonitorC++版本外掛程式

  9. 確認Auto Scaling控制台的警示任務狀態恢複正常。

    2023-12-20_15-13-46.png