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:What do I do if an event-triggered task in Auto Scaling indicates insufficient data?

最終更新日:Mar 26, 2024

If the alarm status indicates insufficient data after you create an event-triggered task in the Auto Scaling console, resolve the issue based on the solution described in this topic.

Problem description

After you create an event-triggered task in the Auto Scaling console, the corresponding alarm status indicates Insufficient Data, as shown in the following figure.

数据不足.png

Cause

The monitoring source of an event-triggered task of Auto Scaling is data in CloudMonitor. The preceding problem may be caused by CloudMonitor not collecting the data of the corresponding ECS instance.

Solution

  1. Log on to the ECS console.

  2. In the left-side navigation pane, choose Deployment & Elasticity > Auto Scaling.

  3. In the left-side navigation pane of the Auto Scaling page, click Scaling Groups. On the Scaling Groups page, find the scaling group that you want to manage and click the scaling group ID to go to the details page of the scaling group.

  4. Click the Instances tab to view and record the ID of the ECS instance.

    The following figure shows an ECS instance on the Auto Created tab.

    ECS实例-en.png

  5. Log on to the CloudMonitor console.

  6. In the left-side navigation pane, choose Cloud Service Monitoring > Host Monitoring.

  7. Enter the ID of the ECS instance in the search box to check whether the CloudMonitor agent is installed in the ECS instance.

    主机监控.png

    • If the 图标3.jpg icon is displayed in the argusagent Status column, the CloudMonitor agent is not installed in the ECS instance. You must click the 图标1.jpg or 图标2.jpg icon to manually or automatically install the agent. For information about how to install the CloudMonitor agent, see Install and uninstall the CloudMonitor agent for C++.

    • If Running is displayed in the argusagent Status column, the CloudMonitor agent is installed in the ECS instance, but no monitoring data is found on the monitoring chart. Proceed to the next step.

  8. Check whether the CloudMonitor agent is running properly.

    For more information, see View the status of the CloudMonitor agent.

    Note

    If an exception occurs on the CloudMonitor agent, we recommend that you restart the agent. For more information, see How can I restart the CloudMonitor agent for C++?

  9. Make sure that the status of the event-triggered task in the Auto Scaling console changes to Normal.

    2023-12-20_15-13-46.png