このトピックでは、サードパーティのホストが [ホストモニタリング] リストから削除されない問題をトラブルシューティングする方法について説明します。
問題
ホストからCloudMonitorエージェントを既にアンインストールしている場合でも、サードパーティのホストを [ホストモニタリング] リストから削除できません。
原因
WindowsホストでCloudMonitorエージェントのインストールディレクトリを削除するか、Linuxホストでrm
コマンドを実行すると、CloudMonitorエージェントを完全に削除することはできません。 この場合、ホストは [ホストモニタリング] リストに引き続き存在します。
解決策
Cloud Monitorコンソールでサードパーティホストの削除に失敗した場合、 CloudMonitorにチケットを起票してください。
サードパーティホストを削除するには、次の操作を実行します。
サードパーティのホストでCloudMonitorエージェントを停止します。
詳細については、「CloudMonitorエージェントの停止」をご参照ください。
説明CloudMonitorエージェントが停止した後、ステップ2を実行する前に数分待ちます。 CloudMonitorに報告されたメトリクスは、集計を待機しています。 したがって、ホストはまだホスト監視リストに存在します。
CloudMonitorコンソールの [ホストモニタリング] リストからサードパーティホストを削除します。
にログインします。CloudMonitorコンソール.
左側のナビゲーションウィンドウで、[ECS モニタリング] をクリックします。
[ホストモニタリング] ページで、削除するサードパーティのホストを見つけ、[操作] 列のアイコンをクリックし、[ホストの削除] を選択します。
サードパーティのホストを削除します。
サードパーティのホストからCloudMonitorエージェントをアンインストールします。
詳細については、「C ++ 用CloudMonitorエージェントのアンインストール」をご参照ください。