What do I do if the system displays the message "no workers available"?
Issue description
No workers are available, and the system displays the message "no worker available."
Cause
Configurations may be incorrect.
Solution
In the SchedulerX console, log on to the worker that you tried to use to connect to SchedulerX and check the log in the following path: /${user.home}/logs/schedulerx/worker.log.
If the process was started by using the admin account, the log path is /home/admin/logs/schedulerx/worker.log.
If the process was started by using the root account, the log path is /root/logs/schedulerx/worker.log.
Search WorkerConfig. Check whether the configurations of the endpoint, namespace, and group ID are correct.
What do I do if the system reports the error "DomainNotFoundException" during an application release?
Issue description
Caused by: com.alibaba.schedulerx.worker.exception.DomainNotFoundException: Not found domainName
Cause
The endpoint may not match the selected region.
Solution
Check whether online workers use the proper endpoint. Local workers can be connected only to the endpoint of the "Internet" region. For more information about the endpoints supported by SchedulerX, see Endpoints.
What do I do if the system reports the error "can not find namespaceId" during an application release?
Issue description
During application startup, the system reports the following error:
can not find namespaceId, key: d783212a9c-5a00-4d00-b8ca-b7a68824c97f
source:schedulerx domain=schedulerx-test.console.aliyun.com
Cause
The configuration of the Namespace parameter may be incorrect.
The region of the instance that hosts the application is different from the region of the namespace that is created in the SchedulerX console.
For example, the namespace is created in the China (Hangzhou) region, but the instance that hosts the application is in the "Internet" region.
Solution
Log on to the Distributed Task scheduling platform. On the Application Management page, find the desired application and click Access configuration in the Operation column to check the configurations.
How do I test local connections in the SchedulerX console?
In the SchedulerX console, switch the region to Internet, create an application, and connect the application to SchedulerX. For more information, see Connect to SchedulerX over the Internet from an on-premises environment.
What do I do if local workers in SchedulerX cannot connect to the Internet?
If the direct connect is normal but you cannot connect local workers to the Internet by using a proxy, you need to specify an endpoint. For information about the regions where you can deploy applications and the endpoints of the regions, see Endpoints.