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:Why am I unable to receive messages after I create an SMQ subscription?

Last Updated:Oct 22, 2024

Issue

After you create a Simple Message Queue (SMQ, formerly MNS) subscription, you are unable to receive messages or find relevant records in logs.

Cause

This may be because you configured the FilterTag parameter when you create the subscription. The parameter specifies the tag that is used to filter messages. Only the messages that have the same tag can be pushed.

Solution

To troubleshoot the issue, perform the following steps:

  1. Check SMQ logs and check whether no relevant records are found. For information about how to view SMQ logs, see Log management.

  2. Check whether you configured the FilterTag parameter when you create the subscription. Keep or discard the parameter based on your business requirements. For information about this parameter, see Subscribe.

If the issue persists, you can log on to Alibaba Cloud Community for free consultation. For more information, see Developer Community.