Problem description
After you use the CDN refresh and prefetch feature, the Accessed resources are not updated.
Cause
There are three common reasons for not updating resources:
- Although CDN cache is cleared by using CDN refresh and prefetch, it is affected by browser cache and leads to access to old resources.
- Because the resource on the origin is not updated, it is an earlier resource.
- The refresh and prefetch tasks are not completed.
Solution
Select a solution based on the cause of the problem.
- Try cleaning up your browser cache and then refresh the page to see if the resource is updated.
- Bind the domain name of your origin server to the origin server by modifying the local host. Then, you can access the origin server and check whether the resources on the origin server are updated. If the requested resource is not updated, update the resource on the origin server and then use CDN again.
- Log on to the CDN console and check whether the refresh and prefetch task is completed. If not, we recommend that you execute the task again. For more information, see configure refresh and prefetch.
Scope
- CDN