This topic describes how to resolve the issue that the following error message appears when you connect to a Windows Elastic Compute Service (ECS) instance by using Remote Desktop: The system cannot find the file specified.
Problem description
When you use your computer to connect to a Windows instance, Prompts the system that the specified file cannot be found.
Cause
This error occurs because the Remote Desktop connection settings for the Windows ECS instance specify an initial program that the system cannot find or start.
Solution
These steps use Windows Server 2008 R2 64-bit as an example. The configuration may differ on other operating system versions. For details, consult your operating system's official documentation.
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Connect to the Windows instance using Virtual Network Computing (VNC).
For more information, see Connect using VNC.
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Choose Start > Administrative Tools > Remote Desktop Service > Remote Desktop Session Host Configuration.
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In the RD Session Host Configuration: section, double-click RDP-Tcp.
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In the RDP-Tcp Properties window, click the Environment tab, select Do not allow an initial program to be launched; always show desktop, and then click OK.
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Verify you can connect to the Windows instance using Remote Desktop without the error.