This topic describes how to troubleshoot the issue that a third-party host fails to be deleted from the Host Monitoring list.
Issue
A third-party host fails to be deleted from the Host Monitoring list even if you have already uninstalled the CloudMonitor agent from the host.
Cause
If you delete the installation directory of the CloudMonitor agent on a Windows host, or run the rm
command on a Linux host, the CloudMonitor agent cannot be completely deleted. In this case, the host still exists in the Host Monitoring list.
Solution
If a third-party host fails to be deleted in the CloudMonitor console, submit a ticket to CloudMonitor.
To delete the third-party host, perform the following operations:
Stop the CloudMonitor agent on the third-party host.
For more information, see Stop the CloudMonitor agent.
NoteAfter the CloudMonitor agent is stopped, wait a few minutes before you perform Step 2. The metrics that are reported to CloudMonitor are waiting to be aggregated. Therefore, the host still exists in the Host Monitoring list.
Delete the third-party host from the Host Monitoring list in the CloudMonitor console.
Log on to the CloudMonitor console.
In the left-side navigation pane, click Host Monitoring.
On the Host Monitoring page, find the third-party host that you want to delete, click the icon in the Actions column, and then select Delete Host.
Delete the third-party host.
Uninstall the CloudMonitor agent from the third-party host.
For more information, see Uninstall the CloudMonitor agent for C++.