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Elastic Compute Service:What do I do if the "Allow Remote Assistance connections to this computer" option in Remote Assistance cannot be selected for an instance that runs Windows Server 2008 or 2012?

Last Updated:Mar 17, 2023

This topic describes how to resolve the issue that the "Allow Remote Assistance connections to this computer" option in Remote Assistance cannot be selected for an Elastic Compute Service (ECS) instance that runs Windows Server 2008 or 2012.

Problem description

When you enable Remote Assistance for an instance that runs Windows Server 2008 or 2012, the "Allow Remote Assistance connections to this computer" option greyed out and cannot be selected.

Cause

The Remote Assistance feature is not installed on the instance that runs Windows Server 2008 or 2012.

Solutions

This section describes the solutions to the issue on Windows Server 2008 and 2012. Use an appropriate solution based on the actual scenario.

Windows Server 2008

  1. Connect to the instance.

    For more information, see Connection methods.

  2. Choose Start > Control Panel > Administrative Tool > Server Manager > Features and click Add Features.

  3. In the features list, find and select Remote Assistance, and then click Next.

Windows Server 2012

  1. Connect to the instance.

    For more information, see Connection methods.

  2. In the Windows taskbar, select Server Manager.

  3. In the Server Manager window, select Add roles and features.

  4. In the Add Roles and Features Wizard window, click Next until the Features list appears, select Remote Assistance, and then click Next.